Skip to the content

installing TXdocs Classic Software

Considerations before you install our desktop software:

  • TXdocs Classic can be installed on your Windows PC or on your office server. It requires a Microsoft Vista or newer operating system (no Windows XP).
  • For TXdocs to work on your computer, please install the same version to which you have subscribed.
  • This is a very large installation program. Depending on the speed of your internet connection, please allow an hour or more for the download to complete. 

Installing on networked computers:  

Click here for additional information.

Install TXdocs or TXdocsPlus:

This includes subscriptions for all practice areas and the subscription for one practice area only (unlimited as well a per-case subscriptions).  Click here to download.


Reference the below if using older Operating Systems:

  • Windows Vista and Win Server 2008 require Service packs 1 & 2
  • Windows Vista - If you receive an error that says "SQL Server Install Failure - Error Code - 2067922335", download and install the file from this link:  Download .Net 3.5 SP1 Update
  • Windows 7 and Win Server 2008R2 require Service pack 1 
  • Windows 8 and newer - (no service packs are required)
  • Windows .Net Framework 3.5 or newer is also required
  • Adobe Reader (for viewing .pdf files):  Download Adobe Reader

Have questions?

Call Us

(210) 253-9506
Mon-Fri 8 am-5 pm CST